Variations on "hole too close to another hole" constraint errors

This has been getting worse for weeks. This morning I opened a project and it had 12 new constraint errors that were not there yesterday. They were all like “U112 hole closer than 0.25 mm to a via.” I would post a screenshot but that does not seem to be possible.

This is absurd. U112 is 2.5 mm clear of any vias. Some of the errors pertain to holes that are on the opposite edges of the same board.

It used to be just one or two of these constraint errors, and they would come and go Now there are armies of them. I am reluctant to ignore all constraint errors in case there is a real one that matters.

Is there a fix for this? I would happily pay for Upverter if it didn’t have these endless problems and if there was some hint that support might be possible.

Rob

Support is pretty much non-existent. Just look at the endless issues from other frustrated posters, and the time between posting and a response from official.

Coming back to your issue, just use the ignore button.
It seems to be caused from movement of components, and it seems that they stack in some situations (ie, they are constantly being generated, but never cleared), hence why you have so many of them.
Just look at some the same ones for me. I even have designs where the reference designators in the constraints are not even existant!

It has got even worse. I am convinced that Altium bought Upverter in order to kill it off. I hope the founders got a decent payout.

I have been trying to ask Altium what the upgrade path from Upverter to CircuitStudio is. Got no straight answer but some glib bot telling me to download it and try it. I am downloading it today and will give it two hours. If it doesn’t work in that time I’ll need to spring for Eagle. I am wasting too much time. If Eagle saves me two hours per month it is way more saving that the $60 they are asking.

Rob

I just wasted 30 minutes with CircuitStudio and Altium non-support. I suppose I should be grateful that they only wasted 30 minutes of my time before making it clear that there is no upgrade path from Upverter to any Altium product.

I still need to get my projects out of Upverter and onto another platform ASAP. Going to try Eagle.

“It has got even worse. I am convinced that Altium bought Upverter in order to kill it off.”

Pretty much yes.

I’m sorry that you’ve been experiencing issues with this. I think many of us have left Upverter for the same reason. No support, too many bugs, downtime at the worst moments. etc…

As an experienced user of Upverter, I can do what I need, given the known limitations of the software, and with a free price tag. I don’t blame you however, for wanting to migrate to better tools.