Upverter crashes every time I try to regenerate a ground pour


#1

I have a 4 layer board and when I try to regenerate any of the pours Upverter crashes. As you can understand I cannot finish my design. Any solutions for this?


#2

I’m having the same issue on a two-layer board - browser (Chrome 62.0.3202.75) crashes generating a ground pour.


#3

Just restarted Chrome and got an update to 62.0.3202.94, still crashes.


#4

+1 Everytime I try to pour it crashed, on very rare occasians it is getting through, driving me nuts. Chrome 62.0.3202.75 on Ubuntu 16.04


#5

I’m affraid I’ll have to join you guys. I"m also trying to pour a ground plane. I can get it to pour correctly when doing only part of my pcb but it crashes every single time I make it any bigger or more complex.


#6

I’ve been experiencing this issue on chrome as well for a few weeks. I just tried with Safari and everything worked fine…


#7

I have also had this problem. It worked once I removed a couple of custom pads I had added on the ground plane. It worked with some of the custom pads of the same type, maybe it just comes down to complexity and overloaded servers?


#8

This post is about this pouring issue, another pouring issue and about pouring my frustration and why I will stop working with upverter after I have finished my latest quickfix.

Another issue related to the pouring is this:

Error: multiple polygons returned for shape outline eda.min-9ebb392b.gz.js:3105:335
	up.genObj.Padstack.prototype.getPolygonOutline https://cdn.upverter.com/static/build/standard/eda.min-9ebb392b.gz.js:3105:335
	up.pcb.engine.Pour.prototype.createThermalSpokes https://cdn.upverter.com/static/build/standard/eda.min-9ebb392b.gz.js:6923:242
	up.pcb.engine.Pour.prototype.calculateShapes_/e.complete< https://cdn.upverter.com/static/build/standard/eda.min-9ebb392b.gz.js:6918:197
	<anonymous> self-hosted:951:17
	up.design.pcb.Pour.prototype.regenerateGeneralPolygons_/c.complete< https://cdn.upverter.com/static/build/standard/eda.min-9ebb392b.gz.js:4616:232
	<anonymous> self-hosted:953:17
	up.design.pcb.PourHelpers.asyncCalculateGeneralPolygon/k.onmessage https://cdn.upverter.com/static/build/standard/eda.min-9ebb392b.gz.js:4592:340

Frustrations and why I am gonna stop using this tool (for starters I started using it mainly because of the simplicity of the tool and the fact that it looks descent, ui wise, compared to all the other tools. Especially in a HDPI monitor on linux, 9 out of 10 other tools are just horrible)

  • There are hardly any good support/docs for this tool, you need some questions answered the forum is the place, but I haven’t found anything answered yet, so you always have to start a topic which is time consuming.
  • There is this pouring issue (see this topic) which makes me go to firefox. But in Firefox none of the shortcut keys work which makes it unworkable too.
  • It is slow, not just in Chrome, also in Firefox, which leads to my browser asking me all the time if I want to close the tab. I bought a Dell XPS 13 9630 couple of months ago, this is a pretty solid laptop that should surely be able to run this tool.
  • Not remembering that I turned of the design rules when you switch between PCB and schematics, that is the one that triggers to always highlight the pour, frustrating…
  • Loading time… sigh
  • And my last item, which I will send you guys an email about, the concierge and verified parts is a lie, I just created a part for $30 just to found out that the pads in the Gerber where completely off! Unfortunately this wasn’t seen until I already let my manufacturer make a couple of boards.
  • Keep asking me to rate it, every single time I log in.

We’re on a mission to make hardware less hard, is your mission statement, sure… Need a bit more work boys, I can hardly get a proper PCB out of it.

I’ve hardly got any parts on my board, and it already crashes and burns my laptop…


#9

I last commented on this thread in November of 2017 - nothing has changed since. I also was able to attend Upverter/Altium’s roadshow event in Boston, where I was assured that the product is not dying and is only going to get better!

Pours simply don’t work. Certainly not on chrome, mostly not on Edge/IE or Safari, and only sometimes on Firefox. I don’t know why the browser matters for the pour, but it does. Chrome/Safari/Edge crash at least 80% of the time when even a basic ground pour is being made on a simple board.

I really want to love Upverter/Altium and this product, but I just can’t be productive using it any longer. I’ve recommended it to tons of aspiring hardware designers and scientists around MIT/Boston due to its mostly fantastic UI, but I just can’t justify that any longer. If I could pay to run it locally on my machine and get around whatever bottlenecks are causing the pours to fail, I would do it in a heart beat, but I doubt that will ever be an option.

It’s been a good run, Upverter. Hopefully, you will figure out and solve whatever issues are causing these massive performance problems.


#10

I 100% agree. I like so many things about Upverter, it really solves many of the pain points I had with other software. But the pour situation needs some serious attention. We shouldn’t have to worry about a design getting too complex to the point we can’t complete the GND pour


#11

Hey guys,

I had the same problem and was able to solve it consistently by using Firefox instead of Chrome - don’t ask me why.

So now I use Chrome for everything until regenerating pours, which I do with Firefox. Fantastic user experience!


#12

Hey,

We are working on replacing the pour code! hopefully we can make it better soon. The issue is memory usage in some cases of the pour regeneration. It is different in different browsers.

We will fix it, I am trying to push for a release as soon as we have a new version that is working for at scale.

Hang in there!

Thanks,

Michael


#13

I wanted to send out an update on this topic.

We are testing the new pour code now, and have a set of users that are using it in Beta, we are hoping to go live at the end of the year.

Thanks,

Michael