Overlapping net points error


#1

Sometimes, when trying to duplicate parts of a schematic using copy/paste, I get things positioned just right and get red dots saying “Overlapping net points”.

I’ve managed to resolve this by deleting the wires and rewiring it. But it seems like there ought to be some way to be able to OK joining the net lists of the overlapping points.

Being a Windows user, the natural approach seems like right-clicking on the red dots (expecting a shortcut menu), but upverter doesn’t seem to support right-click or shortcut menus.


#2

Having a way to “weld” overlapping points together would be useful. The other case where this comes up is when a component gets moved so that one of its pins overlaps a net segment.

In the net movement, component and copy/paste we’ve errored on the avoid auto connection side. The philosophy here is that It’s easier to rip up and re-add a net segment where you get a violation than it is to realize that you’ve accidentally over connected something.

This isn’t something that is on the immediate TODO list, it is an issue we’re aware of though.


#3
  1. I get a Red dot when i intentionally connected it like a plus (+). The Red dot goes away when one of the nets are removed and comes right as soon as the connection is made again. Just unable to get rid of it…desperate.

  2. Get this message “Net x-y-z has > 3 connections and needs an explicit name” but don’t know where to add a name.


#4

Hi,

  1. You can disable this behavior by turning it off in the CONSTRAINTS section in the Top panel.
    Scroll down to the SCHEMATIC RULES subsection and turn OFF [No Four Way Connections].

  2. Select one of the wire from the connection, press i or click on inspect and give it a Net Name other than the Default.

Sébastien Laniel


#5

Thanks @slanAlphaMach for helping out.