Is pcb layout totally broken right now, or just me?


#1

I get page reloads and errors every couple times I touch traces. I’ve tried on multiple computers, mac os, chromebook, linux, and even spun up an IE8 VM. Tried on different schematics, even happens with the example design. Been pulling my hair out trying to get something done for days. Seems like laying traces changed a bit behavior-wise the way it follows the mouse, are you rolling out a new version? If so I think it broke everything…

I’ve also just been trying to get my design out of upverter somehow in the meantime without having to redo it from scratch. No luck with that either. Can’t find anything that will import openjson, the PADS export was broken as well until finally got one to generate this morning, but altium can’t import the file. Even upverter chokes on the openjson file that it generates when I try to reimport my design. Been hacking at the abandoned upconverter github project fixing bugs to salvage as much as I can but I’ll be lucky if I get half of my design into another EDA. I noticed that when I tried to reimport the openjson file, you spit out a python stacktrace error on the upload page and it actually chokes on upconvert.py parser script but on a line number that’s double the number of lines in the version on github. So I guess you have a much more complete version of it in-house. I’m sure many customers would appreciate if you could upload the remainder to github.