How to place a pour on an inner layer?


I am trying to do a four layer board design with pours on all layers. I have been playing with the pour system all morning and I finally figured out you need to have a component with one pad connected to the net of the pour in order to have the pour work on the layer. I have the pours working on the two outer layers with the components. But I am unable to get them working on the two inner layers. I have added vias and traces on the inner layers, connected to the pads on the upper layers, but still nothing is working. Do you need to have a component pad on an inner layer in order to get the pour on the inner layer, because obviously that is impossible. Why are vias from the outer to the inner layers connected to the right net not enough to create the pours on the inner layers?

Can anyone from Upverter help with this? This will be a dealbreaker for me moving forward if there is no way to do pours on inner layers. Would like to continue developing with Upverter but all the bugs, lack of development and lack of support really has me nervous. Is there any workaround for this?

Really unfortunate that Upverter has all these bugs and give no support and no answers. Not even a response that they are aware of the issue, let alone fixing it. I have no choice but to move to KiCAD for now. I really had high hopes for Upverter being cloud-based and owned by Altium, but it seems somewhere along the way it has collapsed and the lights are on but no one is home. I have found so many bugs I have only posted about 30% of them in this forum to avoid overwhelming the forum with bug issues. Coming from Altium, alot of stuff that is basic to PCB design software just doesn’t work right in Upverter, and it should since Upverter is owned by Altium. I don’t see how a company can expect people to remain onboard with them and invest their time developing libraries and projects in a software that is so poorly supported. Good luck Upverter, you are going to need it.

Hi Sam,
Sorry for the delay. I was pulled away on other tasks this week. I will be testing out inner pours today and let you know what works.

Hi Sam,
I’m not having issues with pours on inner layers. Do you have multiple pours that overlap on the same layer? They will not generate correctly if their pour order is the same.
There was a long period of reduced development at Upverter, but, as I’ve mentioned in many other threads, we’ve really picked up the pace. Already a large number of issues in the backlog have been resolved and some cool features, such as the ‘SHIP IT!’ button for ordering through a partner manufacturer, have been added.
We appreciate that you gave Upverter a try! we are working hard to improve the tool and I genuinely hope you come back for another try in the future.
Best of luck with your projects.

I have one pour per layer. How did you get the inner layer pours to work exactly? All I can get is a line along the PCB border to draw on each inner layer. I couldn’t get the bottom copper to pour until I connected one pad on a component on the layer to the net of the pour. Then the eye symbol appeared for the bottom layer pour and it was there.

But for the inner pours I can’t figure out a way to connect a pad since I can’t figure out a way to even place a pad on the inner layers. Placing a via to the inner layer and connecting the via to the net of the pour is not working, so I am interested to know how you got it to work. Maybe it is something obvious I am not seeing.

First create your layers, which you seem to have already done. Then make sure they are visible (the eye is there). You can do that by clicking at that location on the layer pane.

Set the pour you wish to create as the active layer. You do this by clicking on the layer label
active layer

Do your pour as usual.
start pour

Notice the eye is not there at all. This is not the layers pane, this is the pours pane. If the eye is not there then there is no pour on the layer. But as you can see the pour is created on the layer, and it is assigned to a net. It just refuses to pour.

OK I have solved this issue. I had “Island Removal” checked, and because it was all one large pour since nothing is routed on the layer yet, it considered it an island. In Altium you can define island size so that doesn’t happen, so I clicked Island Removal by habit. Good to know for the future. You can consider this issue solved.

Island removal seems buggy to me. When I repour as a hatched outline I get actual islands that should be removed, but when I check “Island Removal” it just removes the entire pour.