[Bug Report] Stop overwriting net visibility


#1

I was debating whether this was a feature request or a bug report, but I think how this behavior is undesired in all situations.

Upverter should not modify which nets are hidden, ever.

Steps to reproduce:

  1. Open up moderately complicated project
  2. In PCB view, go to Net List on right side, make sure all nets are shown
  3. Scroll down to GND net and hide it
  4. Go to schematic view and select a component that has a GND connection
  5. Go back to PCB view

GND net will be shown again.

I don’t believe this should be default behavior. GND should remain hidden until manually re-enabled by the user.

Additionally, sometimes many nets seem to get hidden automatically, or maybe by the user unintentionally, but I haven’t been able to figure out how to reproduce that.